This is AdBlock's old support site. It is available for archival purposes only. To create a new discussion, or to visit the up-to-date knowledge base, please visit help.getadblock.com

AdBlock not working on first opened page

Arthur van Dijk's Avatar

Arthur van Dijk

21 Oct, 2013 07:54 AM

Browser: Chrome
OS: Win 7 Ultimate x64

When an internet page is opened with a link on the desktop or through the app starter when chrome is NOT active, the first time the page loads AdBlock is not working at all. Refreshing the page solves the problem. The setting "Keep Chrome running in the background" is irrelevant.

  1. 1 Posted by memo on 26 Oct, 2013 11:42 AM

    memo's Avatar

    Same here:

    Safari Version 6.1 (8537.71) on OSX 10.8.5

    AdBlock 2.6.4

  2. 2 Posted by Kieran on 11 Nov, 2013 09:45 PM

    Kieran's Avatar

    In Safari 6.1 and 7, Safari sometimes pre-loads pages before the user sees them. The way in which this is done does not give AdBlock the opportunity to block ads on those pages. Apple did not intend to cause problems for AdBlock and is working with us to fix the issue. Once the Safari team has fixed their part of the issue, we will be able to update our code to work with preloaded pages.

  3. Kieran closed this discussion on 11 Nov, 2013 09:45 PM.

Discussions are closed to public comments.
If you need help with AdBlock please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac