This is AdBlock's old support site. It is available for archival purposes only. To create a new discussion, or to visit the up-to-date knowledge base, please visit help.getadblock.com

All streaming - old television series on various web sites - slowed to a snail's pace

Mac Broadway's Avatar

Mac Broadway

01 Nov, 2013 04:47 AM

Whether I'm on my home network (Dish) or at the nursing home (Direct TV) where I "work," when viewing old TV series through watchseries.lt who connects the user (me) to other sites (like movpod.net, daclips.com, gorillavid.com, youtube.com, putlocker, veoh, etc.) where one accesses the files, the playback has slowed to a halting, exasperating crawl.

To cope with the slowdown, I began going to watchseries, through them to the vid I wanted to watch (for example on Gorilla) selecting the vid then when it started streaming, I pressed "pause." The vid would load in RAM in its entirety and I could watch it later with no interruptions.

Problem with that? Perhaps a network problem - built in to discourage streaming by guests at the nursing home - that cuts me off frequently, stopping/interrupting the vid from loading into RAM, and making me start over. Aawwh shucks!

Last week I started watching the old series "Earth Final Conflict." Couldn't get it to upload to my RAM so tried YouTube. Woohoo! YouTube worked really well for 5 days, then started halting every 5 - 12 seconds. The buffer (a gray line that runs ahead of where one is watching) stopped loading, or now takes minutes of waiting to load enough of the vid to watch another 5 - 12 seconds without pausing again.

So - the question -
Since I never had trouble loading YouTube vids before AdBlock, could this trouble be a Safari/AdBlock problem, or do you think it's more a problem with the networks I use, or is it perhaps a cache problem with my MacBook?

Help!

  1. Support Staff 1 Posted by Gabriel on 04 Nov, 2013 10:07 PM

    Gabriel's Avatar

    Hi there!

    Sorry about the delay! The very first thing you should do is visit the site(s) in question, click the stop sign, click "Don't run on pages on this domain", and click "Exclude". Restart your browser for good measure.

    See if that fixes it. If so, the problem is AdBlock. In that case: Please let us know!

    If the problem persists, try disabling/uninstalling AdBlock entirely, restarting your browser, and trying again. See if that fixes it. If so, the problem is AdBlock. In that case: Please let us know!

    If neither of those things works, the trouble isn't with AdBlock, and unfortunately is a little beyond what we're able to help you with.

    Good luck!

    — Gabriel

  2. Gabriel closed this discussion on 04 Nov, 2013 10:07 PM.

Discussions are closed to public comments.
If you need help with AdBlock please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac