This is AdBlock's old support site. It is available for archival purposes only. To create a new discussion, or to visit the up-to-date knowledge base, please visit help.getadblock.com

How to block "Sponsored ads" on Google search results?

mikegrant65's Avatar

mikegrant65

11 Oct, 2015 12:36 PM

I've just installed Firefox (and Adblock of course) on a new PC, and I'm surprised to see "Sponsored ads" at the head of my Google search results which I do not get on my other PC with Firefox and Adblock.

How to block these "Sponsored ads"?

  1. 1 Posted by Kieran on 11 Oct, 2015 05:31 PM

    Kieran's Avatar

    Hi Chas!

    Can you please attach a screenshot with the ad(s) clearly marked? Please be sure to capture the entire browser window.

  2. 2 Posted by mikegrant65 on 11 Oct, 2015 07:43 PM

    mikegrant65's Avatar

    Hello Kieran

    Attached please find screenshot as requested. The top six links are
    sponsored ads.

  3. Support Staff 3 Posted by Rhana on 12 Oct, 2015 04:01 PM

    Rhana's Avatar

    Hi Mike,

    Can you please:

    1. Click the AdBlock button and select Options, then click SUPPORT. Next to "Have our team requested some debug info?" click here. Paste the text from the box into this discussion.
    2. Click the FILTER LISTS tab and then click update now. Does that change anything?
    3. If the problem persists, uncheck all the lists on the filter lists page and reload the page where you’re seeing the problem. Does that change anything?
    4. If unchecking all the filter lists fixes the problem, re-enable the lists one by one, reloading the page where you’re seeing the problem after each. (Make sure to wait for AdBlock to fetch the list before reloading the page.) Which list causes the problem to happen again?
    5. If unchecking all the filter lists did not fix the problem, try the same thing with your browser extensions: Disable all of them, then re-enable the extensions one by one, reloading the problem page after each. Which extension causes the problem to happen again?

    Rhana
    AdBlock Community Manager

  4. 4 Posted by mikegrant65 on 12 Oct, 2015 05:01 PM

    mikegrant65's Avatar

    Tried all your suggestions - nothing changed!

    Info from AdBlock:

    ==== Filter Lists ====
    adblock_custom
      last updated: Sat, 03 Oct 2015 12:24:14 GMT
    easylist
      last updated: Sun, 11 Oct 2015 08:25:57 GMT

    ==== Custom Filters ====
    @@||www.swagbucks.com/$document
    www.amazon.co.uk##DIV[id="sadsfs"]
    www.google.co.uk##DIV[id="f561a376c1f9d9"]
    www.google.co.uk##DIV[id="f561a378529810"]

    ==== Settings ====
    debug_logging: false
    youtube_channel_whitelist: false
    show_google_search_text_ads: false
    whitelist_hulu_ads: false
    show_context_menu_items: true
    show_advanced_options: false
    display_stats: true
    display_menu_stats: true
    show_block_counts_help_link: true
    malware-notification: undefined

    ==== Other info: ====
    AdBlock version number: 2.4
    Total pings: 16
    Platform: winnt
    Architecture: x86
    Name: Firefox
    Version: 41.0.1
    Build: 20150929144111
    Navigator Language: en

  5. 5 Posted by mikegrant65 on 13 Oct, 2015 02:20 PM

    mikegrant65's Avatar

    I managed to fix the problem of the mysterious "Sponsored ads" - it turned out that they were being introduced by a piece of malware by the name of "Fast Search". I ran MalwareBytes and the ads haven't reappeared.

    So, nothing to do with Adblock after all!

  6. Support Staff 6 Posted by Rhana on 15 Oct, 2015 02:30 AM

    Rhana's Avatar

    Hi Mike,

    Glad you were able to track that down! Please don't hesitate to let us know if there's any way we can assist in the future.

    Rhana
    AdBlock Community Manager

  7. Rhana closed this discussion on 15 Oct, 2015 02:30 AM.

Discussions are closed to public comments.
If you need help with AdBlock please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac